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 1 Modification History
Revision Date Comments

1.0 February 28, 2018 Initial Release

 < 1.0.3.1 See ReadMe.markdown 1.0.3.1 included with the release 
package.

>= 1.0.3.1 September 26, 
2019

See the section “What is new and what changed in version 
1.0.3.x”.

 2 What is new and what changed in version 1.0.3.31

 2.1 What is new
1. none

 2.2 What changed
1.  Fixed. Script to merge PDF files doesn't work when MBox Viewer executable and 

configured data folder reside on different drives.
2. Fixed. Page Break stopped working.

 3 LICENSE
The mbox viewer source code created by authors of the mbox viewer project is licensed under 
GNU AFFERO GENERAL PUBLIC LICENSE version 3 which permits free use of the code by 
individuals and organizations. Small portion of the source code is from Code Project site 
and licensed under the Code Project Open License (CPOL) 1.02 which permits, as we 
understand, free use of the that code except in a few unusual cases such as for example the 
immoral usage.

The mbox viewer executable doesn't link any non-free usage library and therefore it can be 
freely used, as we understand, by individuals and organizations.
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The mbox viewer software is distributed in the hope that it will be useful, but WITHOUT ANY 
WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR 
PURPOSE.

Please check the below links for the detailed information on GPL and CPOL license terms.

https://www.gnu.org/licenses/agpl-3.0.txt

https://www.codeproject.com/info/cpol10.aspx

Links to additional publications that can be useful.

https://www.codeproject.com/info/Licenses.aspx
https://opensource.guide/legal/#which-open-source-license-is-appropriate-for-my-project

 4 About this document
Starting with 1.0.3.27 version of MBox Viewer, icons representing folders and mail archives have 
changed. Mail archive used to be represented by the folder icon and now is represented as the stack 
of mail envelops. Mail folder was represented by the computer icon and now it is represented by the
folder icon. However,  not all screen snapshots were updated yet to reflect the change.

 5 Feedback
To help to improve MBox Viewer, please post reviews what works and what doesn’t, create bug 
reports and request for enhancements. Provide as many details as possible, such as country, 
screenshots, etc.

 6 Overview
MBox Viewer (or mboxview) is Windows GUI based program to view mbox files such as 
Thunderbird Archives, Google mail archives or simple Eml files. 

The mbox viewer is a simple but quite powerful email viewer that supports the following features:

1. large file support > 4Gb

2. fast parsing of mbox archives

3. quick access to all attachments

4. preview picture attachments

5. zoom in/out a picture

6. export of single mail in Eml

7. export of all mails in Eml format

8. export attachments of all mails

9. print all or multiple selected mails to CSV or Text or HTML or PDF files or send to PDF printer

10. print single mail to Text or HTML or PDF file or send to PDF printer

11. group all related mails as conversations 

12. print mail conversation/related mails group to CSV or Text or HTML or PDF file or send to 
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PDF printer

13. open single or multiple selected mails or group of related mails in a browser

14. find user defined text in mail’s message and highlight all occurrences

15. search the date, subject, sender, cc, bcc, message text, appendix text and appendix names

16. search for mails that didn’t match the search criteria

17. sort by date, from, to, subject, size and conversation groups

18. support for mail’s header fields and body encoded with different character sets

19. support for mail list editing capability to enable users to compose mail list by merging results of
multiple searches and/or by merging one or more user selected mails

20. ability to set Message Window position to Bottom, Right or Left

21. ability to merge/concatenate multiple archive files and remove duplicate mails

22. ability to customize background colors of display panes and mail message

23. ability to customize HTML/PDF mail header output

24. view raw mail headers

25. forward mails directly from MBox Viewer

26. support for Gmail Labels

27. support for exported hierarchy of mail files from Thunderbird or similar mail clients

 7 Known Issues

 7.1 Mbox/Eml File Names
Non ANSI mail archive file names will likely be silently ignored by the Mbox Viewe and should be 
renamed. 

 7.2 Gmail Label names
Only ANSI characters are supported in Gmail Labels. Also, the displayed labels names may differ 
from received from Gmail if they contain one or more of the following characters:  ? < > : * | \ % . 
The listed characters will be replaced with the underscore character and the unique number will be 
appear at the end the label name. Future releases will attempt to resolve this limitation.

 7.3 Printing to PDF
Mbox Viewer relies on external applications to print directly to PDF. 

Google Chrome browser always prints header and footer which is typically undesired.

Added support for Microsoft Edge browser in v1.0.3.19 to print directly to PDF with no header and 
footer.

Developer version of the Chrome browser called Chrome Canary can also be used to remove header
and footer. Chrome Canary browser may not be fully stable but experience shows it seem to work 
well for printing to pdf.
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User can also leverage free wkhtmltopdf application to print to pdf. The wkhtmltopdf is highly 
customizable but not as reliable as Chrome and the user needs to evaluate whether it works reliably 
in his case. 

Opening group of mails in a  browser and printing from the browser offers additional options such 
as ability to remove color in the output or scale the pages.

 7.4 Opening Multiple Selected Mails in External Browser
Mbox Viewer simply concatenates multiple mails in HTML format into a single HTML file and 
opens the created file within a browser. The format of the created file is as follows:

<div><html><mail 1 header in HTML format></html></div>
<div><html><mail 1 body in HTML format></html></div>
<div><html><mail 2 header in HTML format></html></div>
<div><html><mail 2 body in HTML format></html></div>
<div><html><mail 3 header in HTML format></html></div>
<div><html><mail 3 body in HTML format></html></div>
   …………………

The <div> tags are used in an attempt to create independent sections within HTML document.

The approach doesn’t always work reliably for variety of reasons. One known issue is that some 
mails with content in HTML format rely on default values such as the font size and may inherit the 
font size from other mails. There is currently no work around such issue when viewing mails in a 
browser. 

 7.5 Mail Date and Time
Mails older than the epoch time, i.e. older than year 1970 are supported but the date and time of 
such mails will be mapped to Jan 1 1970.  Windows supports may different date and time functions 
but only Unix style date and time functions support Daylight Saving Time. However, these 
functions do not support date older than year 1970.

 8 Installation
The executable and the source code can be downloaded from Sourceforge or Github.

https://sourceforge.net/projects/mbox-viewer/files/

https://github.com/eneam/mboxviewer/releases

Download the executable package, the latest mbox-viewer.exe-v1.0.3.31.zip,  to the working 
directory and unzip. This will create the mbox-viewer.exe-v1.0.3.31 directory containing the stand-
alone mboxview.exe executable, User Guide, the scripts sub-directory and ReleasePlusStackTrace 
sub-directory. No administrator privileges are needed to install and run the mbox viewer. 

Review the HELP.txt file in case of the Mbox Viewer crash.
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 9 Running MBox viewer
The mboxview program can be executed by double clicking the executable from the explorer 
window or from the command line by typing the command name and argument list to it. 

 9.1 Argument List Summary
The mboxview accept the following command line options.  

-FOLDER=folderPath – the full path to the folder containing one or more mbox or eml files. 
Persists in the registry across multiple runs.

-MAIL_FILE=fileName – full file path or just file name of mbox/eml file to load. If the full path is
not specified, the full path is created from the folderPath and the fileName. Doesn’t persist in the 
registry across multiple runs.

-EML_PREVIEW_MODE command line option to hide Mbox Tree and Mail List panes when -
MAIL_FILE is configured. ESCAPE key will terminate the mbox viewer.

-EXPORT_EML=y|n – enables or disables automatic export of eml files generated from mbox 
archive. Improves traversing performance of mail if set to ‘n”. Persists in the registry across 
multiple runs.

-PROGRESS_BAR_DELAY=seconds – search progress bar is activated when the search duration 
lasts longer than the value set for PROGRESS_BAR_DELAY. If set to -1, the progress bar is 
disables. Default value is set to 1 seconds. Persists in the registry across multiple runs.

-MBOX_MERGE_LIST_FILE=listFile Name and -MBOX_MERGE_TO_FILE=mergedFile 
Name command line options to merge content of mbox files listed in the listFile Name. The merged 
mbox file is automatically open in mbox viewer.

If desired, instead of typing directly desired command line options, a simple .cmd or .bat file can be 
created for convenience and run from the explorer.

 9.2 Setting Options from GUI
The EXPORT_EML and PROGRESS_BAR_DELAY values can be changed on the fly at any 
time from GUI.

Click on the “File” to open the drop menu and then select the “Options” option. The below dialog 
will be presented. Set the desired values followed by OK button.

Note that if exporting of EML files is disabled, you can still export the eml file for the selected mail 
by selecting “View EML” under the “View” drop menu. 

Two options, “Show Charsets” and “Set Character Sets for Header Fields”,  can help to properly
display header fields in the Message Window. See  9.29.1.1 for additional details.

The “Picture Viewer” check box enables/disables the dialog option to preview the picture 
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attachments, see 9.23 for additional details.

The “Enhanced Select Mail Folder Dialog” is different version of the “Select Folder” option and 
allows user to see if the mail archives are in the folder. User needs to select any mail file to select 
containing folder.

The “Time” option allows to display time as Local or GMT.

 9.3 Basic Use Case
Double click of the mboxview to start the viewer. The picture below shows the screen created by 
the mboxview after few steps performed by a user. Mail Archive, Summary and Message windows 
are initially blank after start-up. Steps to load a mail archive and display the content are described 
next.
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1. Click on the “File” to open the drop menu and then select the “Select folder...” option. 
Browse to the folder containing one or more mbox and/or eml mail archive files and select 
it. All valid mail archive files will appear in the Mail Archive Tree window.
Note that different “Select Folder” dialog can be configured via File → Options menu 
dialog.
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2. Left click on one of the archive files to load all mails within that archive.  Progress bar will 
appear and automatically close after the selected archive is fully processed.  Mail header 
information of each email will appear in the Summary window. Note that parsing of very 
large archive file may take some time since the mail archives are text files and every 
character has to be examine one by one.  

However, subsequent loading of mails is done from the index file created by the mboxview 
during the initial parsing of the archive file and is much faster.  The created index file 
contains content meta data of each mail in the archive file. i.e. the mail header information 
and the position of each mail within the mail file for quick access to the mail message/body. 
The index files have the .mboxview suffix.

3. Left Click on one of the mails in the Summary window to show the Message/Body of that 
email in the Message window. The mail retrieval state, total number of mails in the archive 
and the position of the selected mail within the archive is shown on the status bar. Opening a
heperlinks within an external browser is recommended since running Java or scripts or 
ActiveX controls is disabled in the internal browser to improve security.
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 9.4 Multiple Folders Support

Each time you click on the “File” to open the drop menu and select new mail archive folder via the 
“Select folder...” option, the selected folder will be added to list of folders under the Mail Archive 
Tree.

Use +/- icon on the toolbar to expand/collapse the list of archive file under all folders.

To remove folder from the list:

1. Left click on the folder to select the folder and then
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2. Right click on the folder and select Delete Folder menu option

List of the selected folders will persist across multiple runs.

 9.5 Support for Hierarchy of Folders
MBox Viewer can automatically open mail files residing under the root folder and all sub-folders. 
Using this capability, user can more easily view emails exported by Thunderbird or similar email 
clients.

User can select one of two options to leverage this feature.

1. Select “File→Select folder as root folder ...” option. MBox Viewer will traverse root folder 
and all sub-folders and recreate folder hierarchy under the Mail Tree.

2. Select “File→Select root folder for merging ...” option. MBox Viewer will traverse root 
folder and all sub-folders, merge all discovered mbox files and recreate folder structure as 
Gmail style labels.  Duplicate email will be removed.

Option 2, that is merging, allows searching across all discovered mail archives while option1 allows
searching within each folder only.

Screen snapshot illustrates both cases when applied to the same Thunderbird folder.

 9.5.1 Select Root Folder for Merging Configuration Dialog

The following dialog is presented to users upon selection of the “Select root folder for merging..” 
option. In addition to support for folder hierarchy and Gmail style labels, other useful options for 
merging mbox or eml files are supported.
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 9.6 Data Folder Configuration
MBox Viewer will generate files and save them in the user selected data folder when executing 
some of the options such as “Print To...”,  Export All Mails as Eml ..”, etc.

User can select data folder by selecting “File-->Data Folder Config” dialog.
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 9.7 Hiding and Restoring Mbox Files in Mail Archive Tree 
Window

User can hide some mbox files temporarily if he is not actively working with these files and restore 
hidden files later when needed. To hide an mbox file, right click on a file and select “Remove File” 
option.

To restore hidden windows, left click on the folder to select the folder and then right click on a 
folder and select “Restore Removed Folders” option.
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Check files to restore in “Select Files to Restore” dialog.

 9.8 Hiding of Mail Archive Tree Window
User can hide Mail Archive Tree Window to make larger Mail Summary and Mail Message 
Windows. Select button |←or →| to hide/unhide the Tree Window. Tree Window can be hidden only
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when one of the mbox mail files is selected.

 9.9 Message Window Position
Message Window position can be set to Bottom, Right or Left via View→Message Window option. 
After setting new position, mbox viewer needs to be restarted for the change to take effect.

When position is set to Right or Left, the mail address format will change to show mail name only 
or mail address if the name is missing.

By default Message Window position is set to Bottom.
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 9.10 Preservation of Windows Placement
Mbox Viewer will save the windows placement upon exit and restore upon next run.

 9.11 Background Color Style Customization
By default the background color of all display panes is set to the white color. Select the 
“File→Color Style Config” menu option to customize colors of display panes. Left click on the  
Custom button to start customization. The screen similar to the below will be created.

Color Style Configuration dialog allows users to replace the white background of the 8 panes listed 
on the dialog box with the predefined colors or custom colors defined by users.

The dialog offers eight predefined color styles users can evaluate before attempting to configure the
custom color style. It is helpful to open one of the mails with attachments to help to evaluate 
predefined and custom color styles.

Select "Custom" radio button to start configuration of the custom color style.

Configure the same or different color for each pane (MailArchiveTree, etc).

Select one of the panes and left click on the "Pick Color" button to start the "Color Selection 
Dialog".
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The "Pick Color" button will initially be populated with the color associated with the selected pane.

The top raw of the Custom Colors area will initially be populated with the colors associated with 
each pane.

You can change the color in four different areas. The top left section displays a list of 48 predefined 
colors.

If the desired color is not in that section, you can click on the crosshair and drag the mouse in the 
multi-colored palette.

You can also drag the right bar that displays a range based on the color of the palette.

For more precision, you can type the Red, Green and Blue values in the custom color editor area. 
Each uses an integral value that ranges from 1 to 255.

Once you are happy with the custom color, left click on the OK button in

the "Color Selection Dialog". The "Color Selection Dialog" will be closed and control will return to 
the "Color Style Configuration" dialog.

The "Pick Color" button will be painted with the created custom color. Left click on the "Apply" 
button to apply the new color to the selected pane. Left click on the "Apply" button again to cancel 
the change.

Left click on the Save button to save the change in order for the change to persist after the mbox 
viewer shutdown. Or, customize colors of all panes first and then left click on the Save button to 
save all changes.

Left click on the Cancel button to discard all changes made since the last Save or startup.
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Left click on the Close button or standard Windows Close button to hide the "Color Selection 
Dialog". Changes made so far are not discarded.

To reopen, select File -> Color Style Config menu option.

NOTE that the saved color style will be applied to all mails. You can temporarily disable custom 
color style for the active mail by right click on the mail header in the mail message window and 
selecting Enable/Disable Custom Color Style menu option.

 9.12 Support for Gmail Labels
User can perform a separate step to recreate Gmail Labels on Gmail mbox mail archives. Gmail 
Label information is included in every email downloaded from Gmail. To recreate labels, user needs
to right click on an active Gmail mail archive in Tree Pane and select “Gmail Labels → Create” 
option. This will create folders as in example below. Left click on the folder icon to view all mails 
within the label.

Select the folder icon to view all mails again. Button “All Mails and ‘Found Mails” are scoped to 
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the label when a label is selected. Content of “User Selected Mails” is shared across all labels of the
active folder and the folder.

 9.12.1 Limitations

Current implementation has some limitation which will be addressed in the future releases.

Only ANSI characters are supported in Gmail Labels. Also, the displayed labels names may differ 
from received from Gmail if they contain one or more of the following characters:  ? < > : * | \ % . 
The listed characters will be replaced with the underscore character and the unique number will be 
appear at the end the label name.

If you decide to hide/remove the folder from the Tree Pane Via “Remove File” option and later 
restore via “Restore Removed Files” option, Gmail labels will not be automatically restored until 
you restart the Mbox Viewer and recreate the labels. The same applies when you remove and then 
restore a folder.

MBox Viewer startup time might be affected by very large number of labels.
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 9.13 Expand Message Header Field List
When message window position is configured at the bottom, the message header list doesn’t show 
CC and BCC message header fields. This can be changed via “View –> Message Header Pane 
Layout –>Expanded” option.

 9.14 Viewing raw message header
The raw message headers can be viewed in the message window by setting “View → View Raw 
Message Headers” option.  This is the global change and it needs to be disabled to view messages 
content again. The raw message header can be viewed by doing the right click on the message 
header pane and setting  “View Raw Header” option. The setting doesn’t persists when new mail is 
selected.

 9.15 HTML/PDF Mail Header Customization
The HTML/PDF Header Configuration dialog allows users to select mail header fields for output 
and to configure fonts for the field name and field text. User can also configure to output the list of 
all attachments. The customization dialog is selected via “File” --> “Print Config” --> “HTML/PDF
Header Configuration” button.

There are two options to configure fonts: Default and Custom.

The Default option allows to configure:

1. the font size which be applied to both the field name and text.

2. the bold font style which will be applied to the field names only.

The Custom option allows to configure:

1. the same or different font for the header field names and text.

2. the font dialog allows to configure the font name, style and size.

3. the generic family font in addition to the primary font configured via the font dialog.

The following links contain helpful information on HTML fonts.

HTML Fonts 
Fonts and Formatting 
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 9.16 Single Mail Context Menu
Right Click on a selected mail in the Summary Window to open the context menu as shown below.

The “Print to” context menu allows to print the selected mail to Text, HTML or PDF file or to send 
to the user selected PDF printer.

The “Open in Browser” menu option will open the selected mail in the external default Web 
Browser. 

The “Find Text” option allows to find user specified text and highlight all occurrences in the 
Message window.

The “Find Advanced” options will start the advanced search dialog and pre-populate From, To and 
Subject fields from the mail.
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 9.16.1 File Names

User can configure file name pattern/template to apply when printing single mail by selecting File -
> Print Config dialog. Pattern is composed from Date, Time, From, To, Subject and Unique Id 
fields. Only alpha numeric characters are selected from the Subject, other characters will be 
replaced with the underscore. 

Files will be saved in the FolderHousingMailArchives/PrintCache/MailArchiveName folder,  where
MailArchiveName denotes the archive file name without the .mbox extension.

User must enter the target file name manually when printing to PDF printer, i.e. when selecting 
Print to → Printer mail option or when printing mail to pdf file from the browser.

Print Config dialog allows users to configure the maximum length of created file name. The 
maximum file path length supported by Windows is 260 characters for non Unicode applications. 
Therefore the file name will be limited to (260 – length of FolderHousingMailArchives/PrintCache/
MailArchiveName/MailFileName) path. User can set wanted file name length limit and the mbox 
viewer will adjust the configured length if needed.

 9.17 Multiple Selected Mails Context Menu
Multiple mails can be selected using Windows standard method, i.e. Left click followed by 
Shift+LeftClick or CTRL+LeftClick or CTRL+A.

Right Click on a multiple selected email in the Summary Window to open the context menu as 
shown below.

The “Print Selected Mails to” context menu option allows to print the selected mails to single Text 
or HTML or CSV or PDF files or send to the user selected PDF printer.  See also 9.31.7 “Mail 
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Printing to PDF files by Power Users” section.

The “Open Selected Mails in Browser” menu option will open the selected mails in the external 
default Web Browser. 

 9.17.1 File Names

User can’t configure file name pattern/template to apply when printing multiple mails to a single 
file. The file name is automatically composed from the archive file name with appropriate 
extension, i.e. .txt or .htm or .csv or .pdf.

Files will be saved in the FolderHousingMailArchives/PrintCache/MailArchiveName folder, where 
MailArchiveName denotes the archive file name without the mbox extension.

User must enter the target file name manually when printing to PDF printer, i.e. when selecting 
Print Selected mails to → Printer mail option or when printing mail to PDF file from the browser. 

 9.18 Conversation Mail Group Context Menu
All Mails must be sorted by the conversation first before context options can be processed. See 9.25
section.

Right Click on any mail within the selected conversation group in the Summary Window to open 
the context menu as shown in 9.16 section.

The “Print Related Mails to” context menu option allows to print the selected group of mails 
(conversation) to Text, HTML, CSV or PDF file or to send to the user selected PDF printer.

The “Open Related Mails in Browser” menu option will open the selected mail group in the external
default Web Browser. 
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 9.18.1 File Names

See 9.17.1 section.

 9.19 Mail Archive Context menu
Right click on the active mail archive under the Mail Archive Tree Window to open the context 
menu as shown below.

The context menu allows to print all email to single CSV, Text , HTML and PDF files. The name of 
the created file will be created based on the archive file name with the .csv or .txt or .html or .pdf 
suffix in the FolderHousingMailArchives/PrintCache/MailArchiveName folder, where 
MailArchiveName denotes the archive file name without the mbox extension. NOTE that mails will
be printed according to the sort order in the summary window.

Size of HTML file can be very large and opening in most of the browsers can be problematic. 
Microsoft Edge and Google Chrome browser seem to perform best as far as handling large HTML 
files.

When printing to TEXT file, HTML to Text conversion was added in 1.0.2.8 to handle mails with 
HTML text block and no Plain text. Conversion can be quite slow and print time could increase 
significantly compared to 1.0.2.7 in case the large number of conversions is required. Progress bar 
was added to indicate progress, possibly slow progress.

Printing to single PDF file is the most time consuming.  See also 9.31.7 “Mail Printing to PDF files 
by Power Users” sections for larger scale printing to single PDF file.

All mails of the active archive can be sorted by date, from, to subject, size and conversations in the 
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Summary Window. This feature is the same as the left click on the selected column in the Summary 
Window.

The “Properties” option shows the archive file location, size and email count

The “Refresh Index File” option will perform fresh parse of the archive file if needed.

 9.19.1 Print to CSV File Dialog

When printing selected mail archive or selected set of mails by a user to CSV file, user can select 
what fields to export, the date format and one of two time zones.

Option to normalize content encoding is also available. Default encoding is set to UTF-8 and should
not be changed except possibly in special cases.

The “Limit Message to N Characters” value is set by default to 32500 characters and it should not 
be set higher otherwise Excel and LibreOffice will complain that the character count limit per 
spreadsheet cell was exceeded. LibreOffice will gracefully handle the text overflow, Excel 
spreadsheet will get corrupted.

User can configure string that separates attachment names. The special CRLF string will be 
replaced with \r\n string in the CSV output.

 9.20 Mail Attachments
Mail attachments are shown at the bottom of the Message window. Note that the “*’ character may 
appear in the first column for the associated mail to indicate presence of associated attachments. To 
open location of attachments, double click on the mail in the Summary window or select 
“View”→”ViewEML” menu option.  Temporary folder will open containing all attachments for the 
email. Use standard Windows applications to view attachments.

You can also double left click to view attachments. Picture attachments will be viewed in the 
Picture Viewer (if configured in the global Options) and other file types will be viewed by the 
associated default Windows applications.
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 9.20.1 Attachment context menu

Right click on the selected attachment to open the context menu. The context menu allows to open 
or print the attachment by the associated default application. You can also open the folder housing 
the attachment. The selected attachment will be highlighted in the folder.

 9.20.2 Attachments Configuration

Added “Attachment Config” dialog to configure attachment window size, content and attachment 
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indicator criteria. Select “File→Attachment Config” to access the dialog.

 9.20.3 Exporting All Attachments of All Mails

User can export all attachments to the AttachmentCache folder by right clicking on the active mail 
archive and selecting “Export  All Mail Attachments” option. To avoid appendix name clashes, 
Mbox Viewer will prepend the following prefix to each attachment name:

YYYYMMDD-HHMMSS-IDDDDDD attachment name

where YYYY denotes the year, MM denotes the month, DD denotes day, HH denotes hour, MM 
denotes minues, SS denotes second of a mail abd IDDDDDD denotes unique ID assign to this 
email.

 9.21 Inline Image Cache
The mboxview will create the cache of inline images to support images embedded directly into the 
mail body/message. The cache with all images can be created during the initial parsing of the mail 
archive file or subset of images can be created later when needed. Separate cache sub-folder is 
created per each archive file (assuming at least one inline image was found) in the 
FolderHousingMailArchives/ImageCache folder.  If the inline image cache is missing for any 
reason, try to refresh the index file by selecting “Refresh Index File” context option on the 
respective file archive.

 9.22 Export of all Mails to a Separate Eml files
User can export all mails to separate Eml files via mail archive context menu. Right click on the 
selected mail archive and select “Export All Mails as Eml” option. Eml files will created in the 
FolderHousingAllMailArchives/EmlCache/SlectedMailArchiveName folder.
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Mbox Viewer will create Eml file names as follow:

YYYYMMDD-HHMMSS-IDDDDDD name using File Name Configuration under File –> Print 
Config dialog.

where YYYY denotes the year, MM denotes the month, DD denotes day, HH denotes hour, MM 
denotes minues, SS denotes second of a mail abd IDDDDDD denotes unique ID assign to this 
email.
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 9.23 Picture Viewer
Double left Click on any attachment to start Picture Viewer dialog, example below.

The Picture Viewer supports files with the png, jpg, pjpg, jpeg, pjpeg, jpe, gif, bmp, ico, tif, tiff, jfif,
emf, wmf, dib suffixes.

The NEXT and PREV controls enable user to browse all picture/image attachments associated with 
the selected email. You can select specific attachment to be displayed. You can later browse through
all picture attachments.

The ROTATE control allow to rotate clockwise the current/visible picture.

The ZOOM control allows to zoom in/out picture. Click on ZOOM to enable/disable zooming. 
Slide to right to enlarge an image, slide to left to shrink.  Enlarged image can be dragged using the 
left and scroll buttons of the mouse. Click ZOOM to disable zooming and reset the image to 
original size.

The PRINT control allow to print via default application.

The Picture Viewer is enabled by default but it can be disabled via FILE→Options dialog. Setting 
persists in the Registry across multiple runs.
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All attachments are also accessible by double clicking on the selected mail in the Summary window
or by selecting “View”→”ViewEML” menu option.

 9.24 Mail Navigation
Click on a specific mail in the Summary window and use UP, DOWN keys to move to the next or 
previous mail respectively.

Use HOME key to jump to the first mail. Use END key to jump to the last mail.

Use the mouse wheel or vertical bar to scroll up and down mails and then select one of the mails.

 9.25 Mail Sorting
The Summary window is divided into 6 columns: attachment indicator, date, from, to, subject and 
mail size. Each column can be sorted by clicking on the column title. Subsequent click on the same 
column title will reverse the sorting rule. By clicking on the first column title, emails are sorted by 
conversations and mark by different color as shown below.

Mail can also be sorted via the mail archive context menu or by selecting  “File”->“Sort By” menu 
option.

 9.25.1.1 Subject Sorting Rules

Subject sorting creates subject threads, that is a group of mails (or threads) with the same subject. 
Emails within a thread are sorted by time. 

By default the subject threads are sorted alphanumerically. 

Subject threads can sorted by time by selecting “File-→Options→time ordered threads” option.
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 9.26 Dynamic Column Resize
Columns in the Summary windows are automatically resized when the window is resized.

However, if columns are resized manually, some of the columns may no longer be present in visible
area/window. 

You may need to use the scroll bar to see missing columns, otherwise maximize and then restore the
window to see all columns within the Summary window again.

 9.27 Mail Searching
Mbox viewer supports two search options, i.e. basic Find and Advanced Find.

The basic Find option allows users to specify single keyword for searching across header fields, 
mail text, attachment text and attachment names. 

The advanced Find option allows user to specify keyword per each header field, mail text, 
attachment names and attachments.

 9.27.1 Basic Find

The basic Find option allows users to specify single keyword/string for searching across header 
fields, mail text and attachments.  

Users can configure the search scope by selecting all or subset of the from, to, subject, message 
text, attachment names and attachment text options. The search succeeds if the specified keyword 
matches any of the checked fields.

Click the “Edit” drop menu and select “Find” option to configure and start the search. Alternatively 
the CTRL+F will also present the search dialog.

The search dialog box allows user to specify the search string, whether to match the whole word, 
whether the search is case sensitive, configure the search scope, the start and end dates to consider 
for filtering, the Next/Previous search direction and whether to highlight all occurrences of the 
matched text.

Note that the Next search start with the oldest email while the Previous search starts with the latest.

The search logic simple, i.e. mail is considered a match if the search string is found in any of the 
checked fields in that mail.
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To repeat the search in order to find the next matching mail,  click the “Edit” drop menu and select 
“Find again” option, or select F3 key. 

If  “Find again” or F3 key is selected without prior “Find” or CTRL+F, the search dialog box will 
be presented to a user.

 9.27.1.1 Find All Occurrences Option

User can check “Find all occurrences” to find all matching mails. Automatic highlighting of all 
keyword occurrences is not supported in this case. Matched mails will be displayed under the Found
Mails List and the corresponding button in the dialog bar will be highlighted. User can left click on 
All Mails button to switch mail list back to All Mails. 

The basic Find can also be run while in the Found Mails list and while in User Selected Mails list 
when the list is enabled.

 9.27.1.2 Find mails that don’t match option

User can check “Find mails that don’t match” option to find mails that don’t match search criteria.
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 9.27.1.3 Handling of special ‘*’ search string

User can specify single ‘*’ character as the search string to find subset of mails as follows:

1. Find mails that have CC header field by checking out CC check box only.

2. Find mails that have BCC header field by checking only BCC check box only.

3. Find mails that have at least one attachment by checking out Attachment Name check box 
only.

4. Match all mails by checking out any of others check boxes only.

NOTE that if the Find all occurrences option is not selected, user will be traversing the subset of 
mails/matched mails between the start and end dates.

 9.27.2 Advanced Find

The advanced Find option allows user to specify different keyword per each header field, mail text, 
attachment name and attachments.

Users can configure the search scope by selecting all or subset of the from, to, subject, cc, bcc, 
message text, attachment name and text attachments options.

Click the “Edit” drop menu and select “Find Advanced” option to configure and start the search.

The Find Advanced is also available as menu option for the selected mail. Right click on the mail  
and select Find Advanced option. Mbox Viewer will pre-populate From, To and Subject fields in 
this case.
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Only checked fields are use by matching logic and search strings are ignored if present unless field 
is checked.

The search logic is hard-coded for the most common cases. Select “Configure Filter Rule” button to
start dialog and select one of the preconfigured filter rules.        

More complex searching can be achieved by leveraging User Selected mails list. User can run 
multiple advanced searches and merge results into User Selected Mails list.

 9.27.2.1 Find all mails that don’t match option

User can check “Find all mails that don’t match” option to find mails that don’t match search 
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criteria.

 9.27.2.2 Handling of special ‘*’ search string

User can specify single ‘*’ character as the search string in any of the Filter fields to find subset of 
mails as follows:

1. Find all mails that have CC header field by checking out CC check box only.

2. Find all mails that have BCC header field by checking only BCC check box only.

3. Find all mails that have at least one attachment by checking out Attachment Name check 
box only.

4. Match all mails by checking out any of others check boxes only.

 9.27.3 Search Reliability

Searching may not work as expected in all cases due to different character sets on input and in the 
mails.

Base64 or “quoted-printable” text content blocks and text attachments are first decoded before the 
search to eliminate false negative results.

Searching of the header fields is performed on the received raw data.

Raw mail data may contain plain text and/or html text blocks. Both encode the same/similar 
content. If the mail contains plain text blocks, only plain text will be searched. If the mail doesn’t 
contain any plain text blocks, the html text blocks will be searched.

False positive results may happen when searching text/html content blocks since the html tags are 
not ignored when searching. The search string may match one of the html tags and result in false 
positive match.

If possible, use ASCII characters only to compose the search string.

 9.27.4 Search Progress Bar

Search progress bar displays the progress along the configured search string and enables user to 
cancel the search is so desired. The progress bar is not created unless a given search duration lasts 
longer than the delay time controlled by -PROGRESS_BAR_DELAY command line option or 
specified via GUI. Default value is 1 second.

 9.27.5 Search Performance

Searching of header fields performs best since all fields reside in the memory.

Searching of messages and text attachments may take some time for very large files, say larger than 
10-20 Gbytes. Search requires to read the content blocks from the email file and decode the content 
when required. Worse case scenario is when the specified search string is not present in the mail 
archive. When activated, the search progress bar shows the configured search string and enables 
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user to cancel the search is so desired.

Note that when searching of message and text attachments is configured, all mails will be sorted by 
date first, except when sorted by conversations,  to maximize search performance.

 9.28 Refreshing Archive Tree Window
If an additional mbox or eml file is placed in the already selected folder, the Archive Tree window 
needs to be refreshed to see the new additions. This can be done by selecting “Refresh” option 
under the “File” drop menu or by clicking on the button showed below. Individual Folder can be 
refreshed by the right click on the folder and selecting “Refresh Folder” menu option. 

 9.29 Language (Character Sets) Support

 9.29.1 Message Window

Different languages (character sets) are properly supported in the Message Window. This is thanks 
to the Microsoft Web Browser emulation/control class integrated into the mboxview. The mboxview
generates the htm file from the mail’s body and Web Browser displays the generated file in the 
Message window.

Display may not be correct if the character set for the mail’s body is not defined in the mail. To 
resolve the incorrect display, you can try to apply different encoding by right clicking within the 
window, selecting “encoding” and “more” options to apply different language.
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 9.29.1.1 Header of Message Window

The text of the mail header fields is displayed correctly as long as the corresponding field encoding 
type is present in the email. 

Two global options can be used to address incorrect field presentation in the Message Header in 
case the field encoding is not present in the email.  Missing field encoding type may or may not be a
problem. It should not be a problem if the default/local character set installed on your computer 
matches the original encoding of the header fields. It might be an issue if you are receiving emails 
from different countries.

As shown below,  you can see all encoding/character sets applied to the header fields by enabling 
“Show Charsets” option.  To enable, select “Options” from the “File” drop menu and enable “Show 
Charsets”.
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If the field text presentation is not correct, you can try to configure character set (or so called code 
page according to Microsoft terminology) for the selected header fields and see if that helps. Per 
field code pages can be configured via Options dialog box.  Note that the user provided encoding 
doesn't override encoding in the email, if present, which is denoted by the code page greater than 
zero. Code Page set to zero indicates missing or unknown character set.

If you change the code page value(s) in the Options Dialog box, you need to refresh the selected 
email by going up and down (or down and up).

All Windows supported code pages are listed in chapter 12 or can be viewed in the external 
Browser by selecting “View”→”View Code Page Ids”.

The character set information appears after the field title and is formatted as “(character set 
name/code page)”.  The ‘*” star character is appended after the code page if the user specified code 
is applied). Example “(UTF-8/65001*)”.  

The character set information after the “Date:’ title shows the local/default character set installed on 
your computer.

 9.29.2 Summary Window

Mail header fields are displayed correctly as long as the corresponding field encoding type is 
present in the email. 

 9.30 Mail List Auditing
Mail list auditing capability enables users to compose mail list from all mails by merging results of 
multiple searches and/or by merging one or more user selected mails.
To support list auditing, the Mbox Viewer maintains 3 internal mail lists:
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• All Mails list is populated from the selected archive file under the Mail Tree.
• Found Mails list is populated by the search results. User can run Find Advanced dialog or 

set the Find All Occurrences option in the Find dialog.
• User Selected Mails list is composed by a user from the mails in the All Mails and Found 

Mails lists. Mails on All Mails and Found Mails lists are marked by the red vertical bar in 
the first column if they are also on User Selected Mails list.

Each internal mail list has associated button in the dialog bar located next to the tool bar. When a 
particular mail list is shown in the Mail Summary Window, associated button is highlighted.

Access to the User Selected Mails list is disabled upon startup and the associated Button gray out. It
can be enabled by the user to perform simple list auditing if desired by selecting View->User 
Selected Mail List to enable/disable.

When User Selected Mails list is enabled, additional mail menu options will also be enabled such as
Copy Selected Mails to User Selected Mails.

Content of the User Selected Mails list is controlled by the user. User can merge search results with 
the content of the User Selected List.

User can run the search multiples time and merge results multiple times with the User Selected List.
Search results can be pruned before merging.

In addition, user has an option to select/highlight one or more mails in the Summary Mail Window 
and copy to the User Selected Mails list. 

Standard Windows method is used to select and highlight multiple mails, i.e. Shift+Left Click and 
CTRL+Left Click and CTRL+A.

Merging/copying process will not create duplicate mails in the User Selected List.

User can select and highlight one or more mails in the Summary Mail Window and remove from the
active list. Mails can't be removed from the All Mails list.

All Mails list content persists until new mail archive is selected.

Found Mails list content persists until new search or when new mail archive is selected.

User Selected Mails list content persists until cleared by the user or new mail archive is selected.

 9.30.1 Mail List Archiving

Found Mails list and User Selected Mails list content can be saved to new mbox archive files or just
to the .mboxlist mail list files.

Mail Archive and Mail List files will be created in the FolderHousingMailArchives/ArchiveCache/
MailArchiveName folder.

Archive file created from the Found Mails list will be created by appending _FIND suffix to the 
base name of the main archive file name.
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The _USER suffix will be appended when creating archive file from the User Selected Mails list.

For example, if the main mbox archive file from Gmail is called "All mail Including Spam and 
Trash.11.09.2018.mbox", then created archive file will be named "All mail Including Spam and 
Trash.11.09.2018_USER.mbox."

When creation of the archive is completed, user is presented with the dialog to open the folder with 
the created archive file or to open the archive file within the Mbox Viewer.

Separately, user can save mails in User Select Mails list to .mboxlist file, for example "All mail 
Including Spam and Trash.11.09.2018_USER.mbox.mboxlist”.  The .mboxlist files are much 
smaller than the mail archive files. To protect against catastrophic failure of the mbox viewer while 
saving mails to .mboxlist file, the mbox viewer maintains “All mail Including Spam and 
Trash.11.09.2018_USER.mbox.mboxlist.bak1” and “All mail Including Spam and 
Trash.11.09.2018_USER.mbox.mboxlist.bak2” files. To recover, user must copy one of these two 
files to "All mail Including Spam and Trash.11.09.2018_USER.mbox.mboxlist” file.

User can reload the last mail list file into the User Select Mails. Reload can be requested at any time
including after restart of the mbox viewer.

After mbox viewer is restarted or when User Selected Mails List is empty, User Selected Mails list 
can be restored when All Mails list is active.

When User Selected Mails list is active and not empty, it can be reloaded by a user from the 
last .mboxlist file.

WARNING: The .mboxlist file will no longer be valid if the master mail archive is changed.

 9.30.2 Merging Multiple Mail Archives

 9.30.2.1 Merging files using command line options

Multiple Mbox and Eml files (full path) can be listed in a file and concatenated into a single archive
file using two command line options.

-MBOX_MERGE_LIST_FILE=listFile Name and -MBOX_MERGE_TO_FILE=mergedFile 
Name command line options to merge content of mbox files listed in the listFile Name. Wildcard 
file names to merge are supported. The merged mbox file is automatically open in the Mbox 
Viewer.

 9.30.2.2 Merging files from GUI

Multiple archives can be concatenated into a single archive using "File -> Merge Archive Files" 
option.  This is useful if you need to analyze multiple mail views, provided as separate archive files,
derived from the same archive file.
After merging is completed, select "File -> Refresh" to request the Mbox Viewer to discover new 
archive.
In order to remove duplicate mails from the concatenated file:

1. Select the created archive.
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2. Select "View -> User Selected Mails" to enable User Select Mails list.
3. Right click on any mail to select "Copy All into User Selected Mails" option to copy all 

mails into User Selected Mails list.
4. Click on the "User Selected Mails" button to select User Select Mails list.
5. Right click on any mail to select "Remove Duplicate Mails" option to remove duplicate 

mails from User Select Mails list.
6. Mails are considered duplicate if the Date, From, To header fields and unique message ID 

generated by the mail provider match.
7. Select "Save as Mail Archive file" option to save mails on the User Selected Mails list.
8. Select "File -> Refresh" to discover new no duplicate mails archive file by the Mbox Viewer.
9. You may want to rename the default name assigned to the archive file before the above step.

 9.31 Mail Printing Overview
Mbox Viewer supports printing of all, single or multiple mails to CSV, Text, HTML, PDF files and 
to PDF printer.  Mails can also be printed to PDF from any Web Browser by opening mails printed 
to HTML files.

By default all, single or multiple mails are printed to single CSV, Text, HTML and PDF files 
without any additional configuration or manual steps. However there is a limit how many mails can 
effectively be printed to a single file. Option is provided to print mails to separate files to scale to 
larger number of mails. See 9.31.7 section.

The next sections below will cover these limitations and alternate solutions.

 9.31.1 Print Configuration Dialog

Many aspects of printing can be controlled via “File → Print Config” option. The dialog is shown 
below and the usage is covered in the subsequent sections.
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 9.31.1.1 Custom Name Template

User can create custom name template by checking “CUSTOM TEMPLATE” and then selecting 
“Compose Custom Template”. User will be presented with the below template configuration dialog.
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 9.31.2 Mail Printing to CSV Spreadsheet file

By default, Mbox Viewer supports printing of all mails or selected group of mails to a single CSV 
file.  All mails can be printed to single CSV file but a particular Spreadsheet tool may limit the 
maximum supported size of the spreadsheet file.

User can select and print groups/subset of mails to separate CVS files as a work around. There is no
option to automatically split all mails into configurable number of mail groups for printing to 
separate CSV files.

 9.31.3 Mail Printing to TEXT file

By default Mbox Viewer supports printing of all, single or selected group of mails to single Text 
file. All mails can be printed to single TEXT file but a particular Text viewer tool may limit the 
maximum supported size of the text file.

User can select and print groups/subset of mails to separate Text files as a work around. There is no 
option to automatically split all mails into configurable number of mail groups for printing to 
separate Text files

 9.31.4 Mail Printing to HTML file

By default Mbox Viewer supports printing of all mails, single or selected group of mails to single 
HTML file. Mails can also be printed to a separate per mail HTML file for further processing as 
described in “Mail Printing to PDF” 9.31.6 section and “Mail Printing to PDF files by Power 
Users” 9.31.7 section.

All archive mails can be printed to single HTML file but HTML viewer tools/Web Browsers may 
not be able to process large HTML files, become very slow or completely overloaded.

User can select and print groups/subset of mails to separate HTML files as a work around. There is 
no option to automatically split all mails into configurable number of mail groups for printing to 
separate HTML files. 

There is no hard rule how many mails can be printed to a single HTML file and viewed by a Web 
Browser. It depends on the size and content (such as heavy graphics) of mails. It should be doable to
print up to a couple of thousands small to medium size text mails to a single HTML file for further 
processing.

 9.31.5 Mail Printing to PDF printer

Mbox Viewer supports printing of all, single or selected group of mails to PDF printer.

Printing to PDF printer relies on Microsoft HTML Document object to print its content.  First, 
Mbox Viewer will print mails to a single HTML file, then it will load this file into HTML 
Document object and request the document object to print itself.

The limitations as far as the maximum number of mails that can be printed are described in the 
"Printing Mails to HTML file" section.
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The "File -> Print Config -> Page Setup" dialog option allows users to control the page title, header,
footer and background color.

By default user is prompted to select PDF printer for printing mails. If the PDF printer is configured
as the default printer, user can set "File -> Print Config -> Do Not Prompt" dialog option to skip the 
printer prompt step.

 9.31.6 Mail Printing to PDF file

Mbox Viewer supports multiple ways to print all, single or multiple mails to PDF file. All methods 
convert HTML files, created first from mails by the Mbox Viewer, to PDF format.

By default all, single or selected mails are printed to a single HTML file and then converted to PDF 
format. The default method limits the number of mails that can be effectively printed to single 
HTML file as noted in previous sections. More scalable method for is described in “Mail Printing to
PDF files by Power Users” 9.31.7 section.

Mbox Viewer supports an option to print mails directly to PDF file without any user interaction. 
Direct printing to PDF file invokes external application to convert HTML files to PDF.  Standard 
Google Chrome and/or Microsoft Edge browser in so called headless mode are used to perform 
conversion. Using MS Edge allows users to configure printing of pages without header and footer.

Two additional options are provided to leverage developer version of the Google Chrome Canary 
browser and free wkhtmltopdf application to covert HTML to PDF.

Options to leverage the Chrome Canary browser and wkhtmltopdf is provided since the standard 
Chrome browser in the headless mode doesn't support options to control the page title, header and 
footer and the background color. 

The Google Chrome Canary browser can be downloaded from Chrome Canary browser downloads.

User can set "File -> Print Config -> Path To User Defined Script" to invoke HTML2PDF-single-
wkhtmltopdf.cmd script included in the release package. HTML2PDF-single-wkhtmltopdf.cmd 
script creates PDF files with the right footer "Page Number of Total Pages" and no page Title and 
Header. The script can be customized by users if desired. 

The wkhtmltopdf can be downloaded from wkhtmltopdf.org downloads.
The wkhtmltopdf command line options are documented in wkhtmltopdf.org usage.

User can replicate HTML2PDF-single-wkhtmltopdf.cmd or HTML2PDF-single-chrome-
canary.cmd script to a new file and customize to leverage different converter possibly commercial. 
User will need to update "Path To User Defined Script" in "File -> Print Config" dialog to point to 
new script path.

In order to leverage the Chrome Canary browser, user will need to update "Path To User Defined 
Script" in "File -> Print Config" dialog to point to HTML2PDF-single-chrome-canary.cmd script.

When printing multiple mails to a single PDF file, user can 

1. set "File -> Print Config -> Page Break After Each Mail" option to start each mail at new 
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page,  or 

2. set "File -> Print Config -> Page Break After Each Conversation Thread" to start 
conversation or subject thread at new page.

User can unset "File -> Print Config -> Mail Hdr Background Color" option to remove mail header 
background color and save on the ink when printing. Useful option when using Chrome browser to 
print.

User can set/unset "File -> Print Config -> Header and Footer" option to control printing of page 
header and footer via MS Edge browser.

Lastly, HTML files can be open within Firefox, Chrome, MS Edge, etc. Browser and printed to PDF
file. Note that in order for links to attachments be clickable the “Save to PDF” option must be 
used when printing directly from Edge and Chrome browsers.

Note that links to attachments are clickable when PDF document is open in Edge or Chrome 
browser but they are not clickable in Firefox.

 9.31.6.1 Setting Font Size when Printing of Multiple Mails to a Single PDF

MBox Viewer's solution to Print multiple mails to single PDF is non-standard and can affect font 
sizes in all mails. MBox Viewer concatenates content of all mails and headers in HTML format and 
ask Edge or Chrome Web Browser to convert HTML document into PDF.

Some of mails may have complex style definitions and "pollute" environment of other mails. 
Frequently, font sizes become smaller and may need to be zoomed in by the PDF viewer. There is 
no similar solution for zooming when printing generated PDF documents to paper.

The following approach is suggested when printing multiple mails into a single PDF.

1. Print mails using default mode. Right-click on selected mails and select "Print Selected Mails to 
--> PDF --> Default". Evaluate generated PDF document and if not acceptable, follow step 2.

2. Print mails using Merge mode. Right-click on selected mails and select "Print Selected Mails to 
--> PDF --> Merge" option. This will print all selected mails into separate PDF files first and then 
merge them into a single target PDF file. Conversion of mails into PDF format by Edge or Chrome 
Browsers is typically high quality and the merging process typically preserves original quality. Each
mail starts at the beginning of a page in the merged PDF. This may be considered less than optimal 
for small mails. In order to run Merge mode, user must install free java PDFBox command line tool 
and Java VM. Java VM is typically installed on Windows but PDFBox application must be 
downloaded from the following link.

https://pdfbox.apache.org/download.html

Please download the latest pdfbox-app-3.*.jar file and install in the same directory as 
mboxview.exe. Also, check whether java.exe is installed on your system as follow.

Start Command Prompt and type “where java”. If java.exe is not listed in the output, you need to 
install java for Windows. You may also have to update PATH system environmental variable and 
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restart Explorer and MBox Viewer. Evaluate generated PDF document and if not acceptable, follow 
step 3.

3. Set font size to 16px, 20px or 24px for printing. Right-click on selected mails and select "Print 
Selected Mails to --> PDF --> 16px". This will force font size of every text to be set to 16px. This 
may not work well for mails with tables. Font size for text in tables is typically set to smaller to fit 
into table cells.

Note that in approach 1 and 2 you can configure MBox Viewer to print page break after each mail 
or after each conversation thread of mails. Select "File-→Print Config-->PDF document options-
>Page Break After Each Mail/Page Break After Each Conversation Thread".

If none of the above print solutions works for you, you need to print each mail to a separate PDF 
file and use a professional tool such as PDF-XChange Editor to merge generated PDF files into a 
single PDF file. Reliability of these tools was not evaluated. To generate mails to separate PDF 
files, select "File-->Print Config-→Print selected mails to separate files-→PDF".

Performance

Maximum number of mails that can be merged by 1,2 or 3 options depends on the complexity and 
size of mails to be merged.

Merging may take minutes when merging relatively small plain text mails or it may take hours 
when merging large number of business mails with hyperlinks, graphics, tables, etc.

For example, running option 2 (that is merge option), it took 3 hours to print 3926 mails, mix of 
simple and business mails, into separate PDFs and another 40 minutes to merge them by PDFBox. 
Task Manager was showing that PDFBox process memory utilization was close to 8gigabytes.

Option 1 never finished with the same set of mails. I canceled the test when it didn't finish within 5 
hours.

 9.31.7 Mail Printing to PDF files by Power Users

Some users may need to print larger number of mails to a single PDF file. This is supported by 
Mbox Viewer but one or multiple manual steps are required. User must first print all mails to 
separate PDF files and then merge them into a single PDF file by running provided script. 

In order to print mails to separate PDF files, user must first set "File -> Print Config -> Print mails 
to separate files -> PDF" option. After that, using standard mail print to PDF options, user can print 
all or large subset of mails to separate PDF files into sub-folder PDF_GROUP created by Mbox 
Viewer.

Printing large number of mails to separate PDF files is time consuming. Depending on the size and 
content of a single mail, it may take fraction of a second to create PDF file or tens of seconds to 
print single mail.

PDFMerge-pdfbox.cmd script included in the release package can be used to merge PDF files. 
PDFMerge-pdfbox.cmd script invokes free PDFBox java tool to merge PDF files. 
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Free PDFBox java tool can be downloaded from pdfbox.apache.org.

PDFBox command line tools usage example can be found in pdfbox.apache.org commandline tools.

Java 8 can must be installed and can be downloaded from jdk8-downloads.

PDFMerge-pdfbox.cmd script must be copied into the directory housing all per mail PDF files and 
executed. PDFMerge-pdfbox.cmd script will create one or more merged PDF files in the 
PDF_MERGE sub-folder. If more than one merged PDF file is created in the PDF_MERGE sub-
folder, PDFMerge-pdfbox.cmd script needs to be copied to that sub-folder and script executed 
again. The above steps need to be repeated until PDFMerge-pdfbox.cmd script creates single PDF 
file only.

Printing mails to separate PDF files can also be done offline. User must first set "File -> Print 
Config -> Print mails to separate files -> HTML" option. After that, using standard mail print to 
HTML options, user can print all or large subset of mails to separate HTML files into sub-folder 
HTML_GROUP created by Mbox Viewer.

HTML2PDF-all-chrome.cmd or HTML2PDF-all-wkhtmltopdf.cmd script included in the release 
package can then be used to convert HTML files to PDF files. One of these scripts must be copied 
into the directory housing all per mail HTML files, i.e. HTML_GROUP, and executed. Created PDF
files can then be merged into a single PDF file using PDFMerge-pdfbox.cmd script as described 
above.

 9.31.8 Export and Print Directory Structure
MBox Viewer creates data directory and uses as target directory for files and sub-folders created by 
MboxViewer such as “Print...” export all mails as eml files, etc

The DIRECTORY is constructed as follow depending on the selected data folder as described in 
section 9.6.

If the data folder is selected per each folder with mbox files, then DIRECTORY is constructed as 
follow (assuming the mbox folder is not read-only). 

  DIRECTORY=PathToFolderHosingMboxFiles\MBoxViewer

Otherwise, that is, for data folder selected by user or created by Windows,  DIRECTORY is 
constructed as follow:

  DIRECTORY= UserSelectedDataFolder\MBoxViewer\MappedMboxFilePath

Mapping example. Assuming 

MboxFilePath=F:\Account\Inbox.mbox,  then it will be mapped to

MappedMboxFilePath=F\ Account\Inbox-mbox , and DIRECTORY to

DIRECTORY=UserSelectedDataFolder \F\ Account\Inbox-mbox

The ‘:’ character will be removed and “.mbox” extension, if present, will be mapped to “-mbox”
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DIRECTORY - target directory for files and sub-directories created by MBox Viewer
DIRECTORY\MailArchiveFile1.mbox
DIRECTORY\MailArchiveFile1.mbox.mboxview
DIRECTORY\MailArchiveFile2.mbox
DIRECTORY\MailArchiveFile2.mbox.mboxview
 

DIRECTORY\ImageCache
DIRECTORY\ImageCache\MailArchiveFile1- target directory for image files, such as png, jpg, etc, embeded into mails
DIRECTORY\ImageCache\MailArchiveFile2
 

DIRECTORY\ArchiveCache
DIRECTORY\ArchiveCache\MailArchiveFile1- target directory for saving Find Mails and User Selected Mails as .mbox archive files and .mboxlist 
mail list files
DIRECTORY\ArchiveCache\MailArchiveFile2
 

DIRECTORY\PrintCache
DIRECTORY\PrintCache\MailArchiveFile1 - target directory for printing to single CSV, TEXT, HTML and PDF files
z

DIRECTORY\PrintCache\MailArchiveFile1\PDF_GROUP - target directory for printing to separate PDF files
z

DIRECTORY\PrintCache\MailArchiveFile1\PDF_GROUP\PDF_MERGE - target directory for merged PDF files
DIRECTORY\PrintCache\MailArchiveFile1\PDF_GROUP\PDF_MERGE\PDF_MERGE - target directory for merged PDF files if multiple merge 
steps are needed
 

DIRECTORY\PrintCache\MailArchiveFile1\HTML_GROUP - target directory for printing to separate HTML files
z

DIRECTORY\PrintCache\MailArchiveFile1\HTML_GROUP\PDF_MERGE - target directory for merged PDF files
 

DIRECTORY\PrintCache\MailArchiveFile1\HTML_GROUP\PDF_MERGE\PDF_MERGE - target directory for merged PDF files if multiple merge 
steps are needed
DIRECTORY\PrintCache\MailArchiveFile2
DIRECTORY\AttachmentCache\MailArchiveFile1 - target directory for all attachment files
DIRECTORY\AttachmentCache\MailArchiveFile2

DIRECTORY\EmlCache\MailArchiveFile1 - target directory for all Eml files
DIRECTORY\EmlCache\MailArchiveFile2

DIRECTORY\LabelCache - target directory for all Label files

DIRECTORY\MergeCache - target directory for intermediate file created when “File-→Select root folder for merging” is selected.

Mbox Viewer also creates and manages temporary directory C:\Users\UserName\AppData\Local\
Temp\mboxview directory to store temporary files (attachments, eml and htm) created when a 
single mail is selected by the user.

Mbox Viewer created help files such as MailListsInfo.htm and MboxviewerHelp.htm are stored in 
the temporary directory C:\Users\UserName\AppData\Local\Temp\mboxview\MboxHelp directory.

 10 Support for Read Only Media
MBox Viewer supports mbox mail archive files saved on Read Only media such as CDs. 

MBox Viewer will create index files and other internal directories under the writable data directory 
as described sections 9.31.8 and 9.6.

 11 Forward Mails directly from MBox Viewer

 11.1 Overview
Users can forward single or selected group of emails directly from MBox Viewer.  MBox Viewer 
connects to one of the preconfigured SMTP (Simple Mail Transport Protocol) Servers to forward 
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emails.  Emails can be forwarded via Gmail, Yahoo, Outlook Live mail service or user configured 
Mail Service.  

MBox Viewer relies on a separate standalone process, ForwardEmlFile.exe, to connect to SMTP 
Server and to send emails using the TLS encrypted communication. MBox Viewer links proven 
MailKit software library to communicate with the SMTP server. 

Note that ForwardEmlFile.exe can’t access user mail account data since SMTP Server can 
send data only.

Be aware that all Mail Services impose limits on the rate, size of sending mails and other factors, 
see chapter  11.3. For regular users, Gmail seems to offer better more predictable service than 
Yahoo or Outlook. However, Outlook supports mails up to 35MB in size vs 25MB by Gmail and 
Yahoo.

 11.2 User Accounts and Passwords
Mail Service providers usually require third-party applications to follow special authentication 
requirements in order to gain access to their services, i.e. to SMTP Server in this case.

If for whatever reasons you would rather not make changes to your main mail account, you can 
always create additional mail account on another mail service just to be able forward emails directly
from MBox Viewer.

 11.2.1 Yahoo Mail Service

In order for third-party SMTP client applications such as ForwardEmlFile.exe to access Yahoo 
SMTP Server, user must login to Yahoo mail account first and generate one time App Password that
can later be used to authenticate ForwardEmlFile application to SMTP Server. 

App Password is long string of 16 random characters. Using App Password is very safe since it 
practically can’t be guessed by hackers using brute force.

Select the below link and click on + sign next to “Generate an App Password”  and follow all steps 
to generate globally unique password for application named ForwardEmlFile.  You will need App 
Password and Yahoo mail user name to communicate with Yahoo SMTP Server.

https://my.help.yahoo.com/kb/account/generate-third-party-passwords-sln15241.html

 11.2.2 Gmail Mail Service

Third-party SMTP client application such as ForwardEmlFile.exe can connect to Gmail SMTP 
Server and be authenticated using either 1) Gmail user name and Gmail user password,  or 2)  
Gmail user name and Gmail App Password. 

 11.2.2.1 Gmail user didn’t enable 2-step verification to sign up into Gmail

In order to use Gmail user name and Gmail user password, user must login to the Gmail account 
and enable “Less secure app access” option, see the link:
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https://myaccount.google.com/lesssecureapps?pli=1

If you are concerned about this change, you can disable  “Less secure app access” option after you 
are done forwarding emails.

 11.2.2.2 Gmail user did enable 2-step verification to sign up into Gmail

User must login to Google account and generate App Password for Gmail Account.  App Password 
is long string of 16 random characters. Using App Password is very safe since it practically can’t be 
guessed by hackers using brute force.

Use the link below to generate App Password:

https://myaccount.google.com/security

Alternatively, user can login to Gmail account and the select “Manage your Google Account” by 
clicking Google Account icon at the top right corner. Select Security option to generate 16-character
long App Password. See also helpful links below.

https://www.lifewire.com/get-a-password-to-access-gmail-by-pop-imap-2-1171882

https://www.systoolsgroup.com/gmail-backup/turn-off-two-step-verification.html

 11.2.3 Outlook Live Mail Service

Testing was done using Outlook Live free mail account. Microsoft also offers payable Premium 
Outlook mail service under Office 365 and Microsoft 365 plans. These plans offer much higher 
sending limits but no evaluation was performed.

If a user did enable 2-step versification, user needs to generate App Password to be properly 
authenticated, see chapter 11.2.3.2. App Password is long string of 16 random characters. Using 
App Password is very safe since it practically can’t be guessed by hackers using brute force.

If a user didn’t enable 2-step versification, there is no requirement to change any security setting for
Outlook Live account to be able to send mails via Outlook SMTP Server.  

Creating User name and Password to gain access to Outlook SMTP is not exactly clear and can be 
confusing to set up. 

 11.2.3.1 Create Outlook Account, User Name and Password

I suggest the following steps to create valid user names and password.  For more information, 
examine the following link.

Everything you need to know about Microsoft accounts | Windows Community 

In my case I already had Microsoft and Outlook accounts but had to perform additional 
configuration.
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 11.2.3.1.1 You don’t have Microsoft Account (know as MSA) and you don’t have 
Outlook Live account

Use the following link to create Microsoft account page:

https://account.microsoft.com/account

Select “Sign in”, then select “Create one!”, then select “Get a new email address” and create your 
new MyName@outlook.com email address.

The below link has more details.

https://support.microsoft.com/en-us/account-billing/how-to-create-a-new-microsoft-account-
a84675c3-3e9e-17cf-2911-3d56b15c0aaf

Use your new Outlook User name and Password to open SMTP Server Configuration dialog and 
configure user name and password. Attempt to forward one of the mails and check if all works.

 11.2.3.1.2 You already have both Microsoft Account and Outlook Live Account

This is the case I faced. Forwarding of emails was not working properly until I created email alias 
and make this alias primary as described in following link:

https://support.microsoft.com/en-us/office/add-or-remove-an-email-alias-in-outlook-com-
459b1989-356d-40fa-a689-8f285b13f1f2

For some reason,  Outlook Account User Name and Password did not work for me but Microsoft 
Account User name and Password did work.

 11.2.3.2 Generate App Password for Outlook

User must login to Outlook account, enable 2-step verification and generate App Password for 
Outlook Account. Follow the link below to generate App Password:

https://support.microsoft.com/en-us/account-billing/using-app-passwords-with-apps-that-don-t-
support-two-step-verification-5896ed9b-4263-e681-128a-a6f2979a7944

 11.3 Mail Sending and Size Limits
The limits are listed here to the best of our knowledge and they might be changed by the mail 
service providers anytime without notice. For regular users, Gmail seems to offer better more 
predictable service than Yahoo or Outlook. However, Outlook supports mails up to 35MB in size vs
25MB by Gmail and Yahoo.

Users are mainly responsible for observing sending limits. MBox Viewer will limit the sending rate 
to 30 mails/minute.

 11.3.1 Gmail Mail Service

Sending can be rejected by Gmail for variety of reasons. If a user exceeds various limits, user 
account can be locked for up to 24 hours. User can take manual steps to restore access.
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Regular users are allowed to send up to 500 mails per day. 

Mails can be rejected if they are being sent too fast or to too many recipients. 

Mails of up to 25MB are accepted.

 11.3.2 Yahoo Mail Service

Sending can be rejected by Yahoo for variety of reasons. If a user exceeds various limits, user 
account can be locked for up to 24 hours. User can take manual steps to restore access.

Yahoo does not disclose sending and size limits.

Mails of up to 25MB are accepted.

 11.3.3 Outlook Mail Service

Sending can be rejected by Outlook for variety of reasons including suspicion of spamming. If a 
user exceeds various limits, user account can be locked for up to 24 hours. User can take manual 
steps to restore access.

Mails of up to 35MB are accepted. If you attempt to send larger mail, it will appear that the sending
was successful. However, Outlook will post rejection mail into your Outlook account.

The other sending limits are not known.

 11.4 SMTP Server Configuration
Select “File → SMTP Mail Server Config” to open the configuration dialog.  Select one of the 
listed mail services, enter User Account and Password and click on the “Save” button to save the 
changes.

When you select “Close” button, the SMTP.ini file is created for the selected service in C:\Users\
%USERNAME%\AppData\Local\MBoxViewer\MailService and used by ForwardEmlFile.exe to 
support forwarding of emails.

The “Cancel” button is used to clear unsaved changes made in the dialog. If you switch to different 
mail service, the unsaved changes in the dialog are lost.

When you exit MBox Viewer, User Password is not saved in the system for safety reasons and must
be reentered before any mail can be forwarded again.
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 11.4.1 SMTP Servers Default Settings

SMTP Server Address smtp.gmail.com smtp.mail.yahoo.com smtp-mail.outlook.com

SMTP Server Port 587 587 587

SMTP Security StartTls StartTls StartTls

 11.5 Forwarding Mails
MBox viewer supports forwarding of a single and multiple emails.

 11.5.1 Forwarding a single email

Right click on any email and select “Forward Mail” option to open the dialog to forward the 
selected email. The dialog can be manually resized if needed.
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The non-empty To field is required. Other fields are optional. When you open the dialog, To, CC, 
BCC and User Text fields will show the values set in the last dialog. You can clear these fields by 
clicking on the “Clear” button.

It is important to make sure all addresses are correct and valid. If any address is not valid, a 
rejection email will be send by the mail service to the respective user’s mail account. MBox Viewer
doesn’t have access to user’s mail accounts.

 11.5.2 Forwarding a list of selected emails

User can select multiple email, then right click on any of the selected emails and select “Forward 
Mails” option to open the dialog to forward the selected email. 

To avoid suspension of the user account, the user is warned if the user attempts to forward batch of 
emails larger than 100. User is also warned when any of the select mails to forward is larger than 
supported maximum size.

 11.5.3 Error Reporting

If forwarding of a mail fails, MBox Viewer will create Message Box with relevant error text.
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 12 Windows Code Page Identifiers
The table below shows the supported character sets/code pages by Windows platform. The list is 
based on the following link.

https://msdn.microsoft.com/en-us/library/windows/desktop/dd317756(v=vs.85).aspx

Code Page Name Display Name

37 IBM037 IBM EBCDIC (US-Canada)

437 IBM437 OEM United States

500 IBM500 IBM EBCDIC (International)

708 ASMO-708 Arabic (ASMO 708)

720 DOS-720 Arabic (DOS)

737 ibm737 Greek (DOS)

775 ibm775 Baltic (DOS)

850 ibm850 Western European (DOS)

852 ibm852 Central European (DOS)

855 IBM855 OEM Cyrillic

857 ibm857 Turkish (DOS)

858 IBM00858 OEM Multilingual Latin I

860 IBM860 Portuguese (DOS)

861 ibm861 Icelandic (DOS)

862 DOS-862 Hebrew (DOS)

863 IBM863 French Canadian (DOS)

864 IBM864 Arabic (864)

865 IBM865 Nordic (DOS)

866 cp866 Cyrillic (DOS)

869 ibm869 Greek , Modern (DOS)

870 IBM870 IBM EBCDIC (Multilingual Latin-2)

874 windows-874 Thai (Windows)

875 cp875 IBM EBCDIC (Greek Modern)

932 shift_jis Japanese (Shift-JIS)

936 gb2312 Chinese Simplified (GB2312)

949 ks_c_5601-1987 Korean

950 big5 Chinese Traditional (Big5)

1026 IBM1026 IBM EBCDIC (Turkish Latin-5)

1047 IBM01047 IBM Latin-1

1140 IBM01140 IBM EBCDIC (US-Canada-Euro)
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Code Page Name Display Name

1141 IBM01141 IBM EBCDIC (Germany-Euro)

1142 IBM01142 IBM EBCDIC (Denmark-Norway-Euro)

1143 IBM01143 IBM EBCDIC (Finland-Sweden-Euro)

1144 IBM01144 IBM EBCDIC (Italy-Euro)

1145 IBM01145 IBM EBCDIC (Spain-Euro)

1146 IBM01146 IBM EBCDIC (UK-Euro)

1147 IBM01147 IBM EBCDIC (France-Euro)

1148 IBM01148 IBM EBCDIC (International-Euro)

1149 IBM01149 IBM EBCDIC (Icelandic-Euro)

1200 utf-16 Unicode

1201 unicodeFFFE Unicode (Big-Endian)

1250 windows-1250 Central European (Windows)

1251 windows-1251 Cyrillic (Windows)

1252 Windows-1252 Western European (Windows)

1253 windows-1253 Greek (Windows)

1254 windows-1254 Turkish (Windows)

1255 windows-1255 Hebrew (Windows)

1256 windows-1256 Arabic (Windows)

1257 windows-1257 Baltic (Windows)

1258 windows-1258 Vietnamese (Windows)

1361 Johab Korean (Johab)

10000 macintosh Western European (Mac)

10001 x-mac-japanese Japanese (Mac)

10002 x-mac-chinesetrad Chinese Traditional (Mac)

10003 x-mac-korean Korean (Mac)

10004 x-mac-arabic Arabic (Mac)

10005 x-mac-hebrew Hebrew (Mac)

10006 x-mac-greek Greek (Mac)

10007 x-mac-cyrillic Cyrillic (Mac)

10008 x-mac-chinesesimp Chinese Simplified (Mac)

10010 x-mac-romanian Romanian (Mac)

10017 x-mac-ukrainian Ukrainian (Mac)

10021 x-mac-thai Thai (Mac)

10029 x-mac-ce Central European (Mac)

10079 x-mac-icelandic Icelandic (Mac)
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Code Page Name Display Name

10081 x-mac-turkish Turkish (Mac)

10082 x-mac-croatian Croatian (Mac)

12000 utf-32 Unicode (UTF-32)

12001 utf-32BE Unicode (UTF-32 Big-Endian)

20000 x-Chinese-CNS Chinese Traditional (CNS)

20001 x-cp20001 TCA Taiwan

20002 x-Chinese-Eten Chinese Traditional (Eten)

20003 x-cp20003 IBM5550 Taiwan

20004 x-cp20004 TeleText Taiwan

20005 x-cp20005 Wang Taiwan

20105 x-IA5 Western European (IA5)

20106 x-IA5-German German (IA5)

20107 x-IA5-Swedish Swedish (IA5)

20108 x-IA5-Norwegian Norwegian (IA5)

20127 us-ascii US-ASCII

20261 x-cp20261 T.61

20269 x-cp20269 ISO-6937

20273 IBM273 IBM EBCDIC (Germany)

20277 IBM277 IBM EBCDIC (Denmark-Norway)

20278 IBM278 IBM EBCDIC (Finland-Sweden)

20280 IBM280 IBM EBCDIC (Italy)

20284 IBM284 IBM EBCDIC (Spain)

20285 IBM285 IBM EBCDIC (UK)

20290 IBM290 IBM EBCDIC (Japanese katakana)

20297 IBM297 IBM EBCDIC (France)

20420 IBM420 IBM EBCDIC (Arabic)

20423 IBM423 IBM EBCDIC (Greek)

20424 IBM424 IBM EBCDIC (Hebrew)

20833 x-EBCDIC-KoreanExtended IBM EBCDIC (Korean Extended)

20838 IBM-Thai IBM EBCDIC (Thai)

20866 koi8-r Cyrillic (KOI8-R)

20871 IBM871 IBM EBCDIC (Icelandic)

20880 IBM880 IBM EBCDIC (Cyrillic Russian)

20905 IBM905 IBM EBCDIC (Turkish)

20924 IBM00924 IBM Latin-1
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Code Page Name Display Name

20932 EUC-JP Japanese (JIS 0208-1990 and 0212-1990)

20936 x-cp20936 Chinese Simplified (GB2312-80)

20949 x-cp20949 Korean Wansung

21025 cp1025 IBM EBCDIC (Cyrillic Serbian-Bulgarian)

21866 koi8-u Cyrillic (KOI8-U)

28591 iso-8859-1 Western European (ISO)

28592 iso-8859-2 Central European (ISO)

28593 iso-8859-3 Latin 3 (ISO)

28594 iso-8859-4 Baltic (ISO)

28595 iso-8859-5 Cyrillic (ISO)

28596 iso-8859-6 Arabic (ISO)

28597 iso-8859-7 Greek (ISO)

28598 iso-8859-8 Hebrew (ISO-Visual)

28599 iso-8859-9 Turkish (ISO)

28603 iso-8859-13 Estonian (ISO)

28605 iso-8859-15 Latin 9 (ISO)

29001 x-Europa Europa

38598 iso-8859-8-i Hebrew (ISO-Logical)

50220 iso-2022-jp Japanese (JIS)

50221 csISO2022JP Japanese (JIS-Allow 1 byte Kana)

50222 iso-2022-jp Japanese (JIS-Allow 1 byte Kana - SO/SI)

50225 iso-2022-kr Korean (ISO)

50227 x-cp50227 Chinese Simplified (ISO-2022)

51932 euc-jp Japanese (EUC)

51936 EUC-CN Chinese Simplified (EUC)

51949 euc-kr Korean (EUC)

52936 hz-gb-2312 Chinese Simplified (HZ)

54936 GB18030 Chinese Simplified (GB18030)

57002 x-iscii-de ISCII Devanagari

57003 x-iscii-be ISCII Bengali

57004 x-iscii-ta ISCII Tamil

57005 x-iscii-te ISCII Telugu

57006 x-iscii-as ISCII Assamese

57007 x-iscii-or ISCII Oriya

57008 x-iscii-ka ISCII Kannada
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Code Page Name Display Name

57009 x-iscii-ma ISCII Malayalam

57010 x-iscii-gu ISCII Gujarati

57011 x-iscii-pa ISCII Punjabi

65000 utf-7 Unicode (UTF-7)

65001 utf-8 Unicode (UTF-8)

 12.1 Handling Unknown Code Page Names
In a few cases, mboxview will map unknown code names to the equivalent code names supported 
by Windows.

Unknown Code Name Mapped To Code Name

gbk GB18030

cp1252 Windows-1252

ascii us-ascii

cp819 iso-8859-1

latin1 iso-8859-1

latin2 iso-8859-2

big-5 big5

SJIS shift_jis
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